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How to Mail Merge PDF Documents 
A step-by-step guide to creating personalized documents using 
AutoMailMerge™ plug-in for Adobe® Acrobat®  
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What is a mail merge? 
 
Mail merge is a computer term describing the production of multiple (and potentially large numbers of) 
documents from a single template form and a structured data source. This technique is used to create 
personalized letters, documents, bills and pre-addressed envelopes or mailing labels for mass mailings 
(or document creation) from a database of names and addresses. 

What do I need to start? 
 
You need a PDF form (a PDF document with fillable fields) and a data file that contains records with 
information that needs to be placed into the form. You can use Microsoft Excel spreadsheets, Microsoft 
Access database or simply a plain text file. Let’s start from scratch and create a PDF form and a data file. 

 Step 1: How to create a PDF form? 
 
PDF form is a special kind of PDF document that contains interactive fields where text information can 
be entered or check boxes may be selected. You can create a PDF form from any PDF, word processor, 
image file or a paper document. You will need to add fields to the regular PDF document using form 
editing tools provided by Adobe Acrobat. Fields are interactive elements where user can either type text 
or make a selection.  If you already have a PDF document you want to use as a template, then select 
“File > Open” menu and load this document into Adobe Acrobat: 
 

  
 
If you have a Microsoft Word document, then either print it to a PDF printer or save it as PDF using 
Microsoft Word "File" menu. You can also use “File > Create” menu in Adobe Acrobat to create a PDF file 
from many popular file formats or by scanning a paper document. 

Step 2: How to add fields to a PDF document? 
 
We are assuming that you have already created a PDF document at this point and have it open in Adobe 
Acrobat. The actual selection of steps depends on the version of Adobe Acrobat you are using. If you are 
using older versions of Adobe Acrobat, then select “Form > Edit Fields…” (or similar) from the Acrobat 
menu to start adding  fields.  
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Using Acrobat DC to Add Form Fields 
 
If you are using Acrobat DC, then open a PDF document, select "Tools" on the main toolbar and find 
"Prepare Form" tool. Double-click on the "Prepare Form" icon to open a PDF form editor: 

 

If a currently open document does not contain any form fields, then you would be prompted to either  
select an existing file or scan a paper document. Click "Start" button to use a currently open document: 
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Once a document is open in a form editor, click on "Add a text field" icon located on the top toolbar: 

 

Move cursor to a page location where you want to place a text field. You would see a moving blue 
rectangle that represents a field. Press and hold left mouse button and drag a rectangle where you want 
to place a text field. You will be able to change field position and size at any time: 

 

Once the text field is placed, you would be prompted to enter a field name: 

 

The newly added field will be shown in the "Fields" list on the right-hand side of the screen: 

 
 
Proceed to "Customizing Field Properties" section for the rest of the instructions.  
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Using Acrobat X / XI to Add Form Fields 
 
If you are using Adobe Acrobat X or XI, then open “Tools > Forms” panel and click on “Edit…” icon. 
 

 

Once a document is open in a form editor, click on “Add New Field” icon: 

 

 
 
Select a field type you want to place on the document  and use mouse to place a text field on a page. 
Press and hold left mouse button and drag a rectangle where you want to place a text field. 
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Customizing Field Properties 

The following popup window appears on the screen once a field is placed on the page: 

 
Adobe Acrobat by default automatically gives all new fields a name such as “Text1”, “Text2” and so on. 
You can change field name to something more informative:

 
You will use field names later in the mail merge where it is necessary to assign what data fields are used 
to populate a specific form field. Click on “All Properties” link to edit field properties if necessary:  
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Check "Read Only" option if it is necessary to protect a text field from any editing by the reader. Fields 
marked as "Read Only" are non-editable. 
Check "Required" option if it is necessary to force users to enter a value into the field. Users will be 
required to enter information into this field and not allowed to leave it blank. 
 
If you want to change text font or color, then select “Appearance” tab and use "Font Size" and "Font" 
menu to choose desired text appearance. Make sure that field is big enough to display a required 
number of characters while using selected font settings. 

 

IMPORTANT: The resulting PDF file size can be greatly affected by selecting certain fonts. It is suggested 
to use several of the basic fonts to avoid file size increase. These fonts are listed at the top of the font 
list and comprise of the followings styles: Courier, Helvetica, and Times New Roman. 
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If a text field needs to hold multiple lines of text, then select “Options” tab and check “Multi-line” 
option: 

 

Make sure that text field is tall enough to show required number of text lines. You can do that by either 
typing text into the field or specifying a default value: 
 

 
Press “Close” button in "Text Field Properties" dialog once you have finished editing all field properties. 
Repeat the above procedure for every field you need to add to this PDF document. You can access 
properties of any PDF field at any time by right-clicking on it and selecting "Properties..." from a popup 
menu. Make sure to exit form editor once done adding form fields, otherwise some menu items will be 
inaccessible. Use "File > Save" menu to save changes to a file.  
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Using PDF Forms with Free Adobe Acrobat Reader 
If you are planning to let recipients of the form use a free Adobe Acrobat Reader to fill and save this PDF 
form, then you need to enable “extended rights” for this document. Do this as a last stage (after all 
editing have been done) since once extended rights are enabled any changes to the document will 
invalidate such rights and you have to do it again. The actual menu selection for enabling extended 
rights in Adobe Acrobat Reader is different depending on the version of Adobe Acrobat used: 

Acrobat DC: Use "File > Save As Other > Reader Extended PDF > Enable More Tools" menu. 
Acrobat X/XI: Use “File > Save As…> Reader Extended PDF > Enable Additional Features…” menu. 
Acrobat 9 and before: either use "Advanced" menu or check software manual for version-specific 
instructions.  

Once you are done editing the form use “File > Save” menu to save changes. Now this PDF form is ready 
for the mail merge. You can check for extended rights any PDF document by selecting "File > Properties" 
and then choosing "Security" tab (note a special message at the bottom of the dialog screen): 
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Step 3: How to prepare data? 
In many cases you may already have data that needs to go into the form in some kind of spreadsheet or 
database. If you do not have one, then we are going to show how to create a very simple data file using 
just Notepad text editor. Let’s assume we are trying to fill W-2 forms for company employees. We need 
to create a data file that lists first and last name for each employee. Simply open Notepad editor and 
type the following text: 
 

 
 
Note that a first line contains comma separated field names (“First Name” and “Last Name”) while the 
rest of the file contains actual data. Make sure to separate each field by a comma or tab. You can use 
both types of files with AutoMailMerge software. Save this data file with either CSV extension (if you are 
using comma as a separator) or TXT (if you are using tab). Now all data is ready to be used for a mail 
merge. 

 You can also use Microsoft Excel to prepare the data. It is going to be easier since there is no need to 
type commas or any other field separators. Note that the first row of the spreadsheet needs to contain 
unique field names: 
 

  
  
You can either keep automatic sheet name (such as Sheet1) or rename the worksheet to something like 
"Employees". This will help to organize data if multiple sheets are going to be stored inside an Excel file.  
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Step 4: How to put data into forms? 
We are assuming that at this point we have a PDF form with two text fields (“First Name” and “Last 
Name”): 
 

 
 
and Employees.xlsx Excel spreadsheet that was created at step 3. Let’s start to populate our PDF form 
with data from Excel file and create 4 new PDF documents using AutoMailMerge plug-in for Adobe 
Acrobat (http://www.evermap.com/automailmerge.asp). One output document is created for each 
record in a data file. Since we have 4 records in our test spreadsheet, then 4 personalized output files 
are going to be generated. Make sure you have either a full or trial version of AutoMailMerge software 
installed on your computer in order to perform the rest of this tutorial. 

4.1. Start Adobe Acrobat and open a PDF form using “File > Open” menu. This will open a PDF form we 
are going to fill with data (this is a simplified W-2 form with just 2 fields): 

 

 
 

http://www.evermap.com/automailmerge.asp
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4.2. Select  “Plug-ins > Mail Merge…” from Acrobat menu to start AutoMailMerge.  
 

 

If you already have mail merge settings prepared and saved as settings file (*.mms), then you can load 
the settings by pressing "Load Settings..." button.  

4.3. Press “Edit Settings…” button to start configuring mail merge options. This will show a wizard-style 
dialog that would provide a way to specify all mail merge settings in step-by-step fashion. 
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4.4. The "Select Data Source". screen provides a way to select a data file and specify data-to-PDF field 
mappings. This screen can be also used to select a subset of the data records to run mail merge only for 
data records that meets a specific search criteria. 

 
 
Press “Browse…” button to select a data file. You will be presented with a choice of possible input data 
source types. 
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 Select “Microsoft Excel Worksheet” from the list: 
 

 
 
Select the input spreadsheet file in “Open” dialog: 
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Select “Employees” from a list of available Excel sheets (the actual selection of sheets is different 
depending on the specific file): 
 

 

Press “OK” button to confirm selection.  

4.5. The next step is to assign correspondence between spreadsheet data fields and PDF form fields. 
Double-click on a PDF Form field name in the list of available fields to assign what data field(s) to use for 
filling it. Alternatively, you can press "Add Field Mapping" button. 

 

You can save time by naming PDF form fields with the same names as corresponding data fields. This 
would allow using automated field mapping procedure. Press  "Guess Mapping" button to automatically 
assign field mappings based on name similarity. For example, if there are PDF and data fields both 
named "First Name", then a corresponding mapping will be automatically added. 
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4.6 . Select a data field that needs to be used to filling from a list of available data fields in "Select Data 
Field" dialog. It is also possible to put multiple data fields into a single PDF field by using multiple-field 
expressions. Press "Learn More..." button to access documentation for more details. 

 
Press “OK” button to make an assignment and close the dialog. Repeat last two steps for each field that 
needs to get text from a spreadsheet. You should see the following once you have completed the 
assignment (the list of fields will be different depending on PDF form and data file used): 
 

 
Each PDF form field has now a corresponding spreadsheet field assigned. Press “Next >” button to move 
to the next step once you have mapped all fields.
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4.7. Use "Specify Field Options" screen to control if output form fields should remain editable or not. 
Check "Flatten output PDF documents" option to make all fields in output documents non-editable. If 
this option is selected, then all fields in output documents will be converted to text. 

Uncheck "Flatten output PDF documents" option if you need to have content of form fields to remain 
editable in the output files. 
 

 
 
Press “Next >” button to move to the next step. 
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4.8. Use "Select Output Options" screen to control where and how to save output PDF documents. 
Choose output folder by pressing a “Browse…” button and selecting a desired output folder: 
  

 

Leave default settings that will name each output file using input file name and an auto-incrementing 
number. For example, if you are using MyForm.pdf file as input, all output files will be named 
MyForm1.pdf, MyForm2.pdf, MyForm3.pdf and so on. Software offers a number of different options 
including using data fields anywhere in the file name. It is possible to automatically name output files as 
John Doe.pdf, Mary Smith.pdf and etc. 
Press “Next >” button to move to the next step once you are done specifying file options. You can skip 
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all remaining screens (“Add Watermark”, “Select Document Security”, “Select E-mail options” and etc.) 
by clicking on “Next >” button if you are not interested in any additional options. Everything is now 
ready for running a mail merge.  

4.9. Optionally, save mail merge settings into *.mms file for later reuse by pressing "Save Settings" 
button. Use "Load Settings" button to load settings back. 
 

 
 
4.9. Press “OK” button located on the main screen to start producing output documents: 
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4.10.  Press “Run Mail Merge” button on "Confirm Processing" dialog to start mail merge processing: 
 

 

You should see “Mail Merge Results” dialog once a mail merge is completed. This dialog will list any 
errors that occurred during the processing.  
 

 

Press “OK” button to close this dialog and open an output folder where generated PDF files are stored. 
Examine output files by opening them in Adobe Acrobat to see if they satisfy project requirements. 
Make adjustments to processing settings and run mail merge again, if necessary. 
 
You can read more in-depth information about various options offered by AutoMailMerge software in 
the product user’s guide. Select “Help > Plug-in > AutoMailMerge…” from Acrobat menu to access the 
software manual. 

Visit http://www.evermap.com/automailmerge.asp for a detailed product overview and to download a 
free 30-days trial version of the software.  

http://www.evermap.com/automailmerge.asp
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Advanced Topic 1: Checking PDF Check and Radio Boxes 
Check and radio boxes work in the same way as text fields. There are not "checked" or "unchecked", but 
they are filled with text. If a checkbox's "value" matches an "export value" defined by specific checkbox 
field, then Adobe Acrobat displays this checkbox as “checked”. If these two values do not match, then 
checkbox appears unchecked. “Export value” for a checkbox is defined by the designer of a PDF form 
and can be found in each field’s properties (see below for details how to view and edit it). You can assign 
any text for the export value and use any text to “fill” a checkbox. Both values are always treated as text.  
How  to see or change "Export Value" of the check or radio box field: 
1. Start Adobe Acrobat form editor by using "Prepare Form" tool (in Acrobat DC). 
2. Right-click on the checkbox field. 
3. Select "Properties..." from a popup menu. 
4. Select "Options" tab and verify or edit "Export Value" entry box. Use content of the "Export Value" to 
check this particular checkbox field when filling it with data. 

 

By default, "Export Value" is set to "Yes" for all newly created checkboxes.  
Note that the "Export Value" is case-sensitive. It needs to be filled exactly with "Yes" in order to appear 
checked, not "yes" or "YES".  
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Advanced Topic 2: How to Create Multiline Address Labels 
One of the most common mail merge tasks is adding mailing addresses to newsletters, brochures and 
other mail correspondence. Please follow these simple steps if you want to add personalized mailing 
addresses from your customer database or spreadsheet to your correspondence.  

1. First, add a single text field to your PDF document that is going to hold a mailing address. Refer 
to the beginning of this document for detailed instructions on how to add form field to a PDF 
document. Name this text form field something like “Address”. Make sure that this text box is 
large enough to hold 4-5 lines of text. 

 
2. Right-click on the form field and select “Properties…” from popup menu. You should see a field’s 

“Text Field Properties” dialog to appear on screen. 
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3. Select “Options” tab and check “Multi-line” option. This option will allow this field to hold 

multiple lines of text. 
 

 
 

4. Press “Close” button to close “Text Field Properties” dialog. 
5. Save your PDF document with newly added form field by selecting “File > Save As…” from the 

menu.. 
6. Select “Plug-in > Mail Merge…” from the menu to start a mail merge. 
7. Press “Edit Settings…” button to start configuring settings for the mail merge. 
8. Press “Browse…” button and select input data source file. 
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9. Double-click on the “Address” form field in the list of available fields: 

 
10. Check “Use a multi-field expression to create a composite field” option and type an expression:  

[First Name] [Last Name] 
[Address 1]  
[Address 2} 
[City], [State], [ZIP] 
The expression assumes that data fields such as "First Name", "Last Name", "Address 1" and etc. 
actually exist in the input data file. Any text inside [...] is treated as a data field name. All other 
text is treated as static text and will be inserted into output "as-is". 
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11. Press “OK” button to close “Select Data Field” dialog. Complete the rest of the configuration 
wizard. Run mail merge to produce output documents. 
 
Mailing addresses in your document should look like the following (sample): 
 

John Doe 
2397 NW Pacific Drive 
Corvallis, OR, 97330 
 
The plug-in automatically removes any blank lines in the text if a certain data fields (such as 
“Address 2”) are empty. Use {blank} keyword if it is necessary to preserve a blank line in a 
composite field: 
 
[First Name] [Last Name] 
{blank} 
[Address 1]  
[Address 2} 
[City], [State], [ZIP] 
 
The above expression produces the following output (sample): 
 
John Doe 
 
2397 NW Pacific Drive 
Corvallis, OR, 97330 
 
Examine output documents to make sure that the size of the text form field is sufficient to hold 
amount of text from the all data records. Enlarge the field if text appears to be cut off on some 
of the output forms or reduce font size. You can change size and visual appearance of the text 
field (such as font and color) by editing it in Acrobat form editor.  
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Advanced Topic 3: Automatic Emailing of PDF forms 
The AutoMailMerge plug-in provides ability to automatically send populated PDF forms to email 
recipients.  
1. The first step is to put email addresses for each data record/recipient into a data file. For example, 
add "Email" column to the Excel spreadsheet: 

 

2. In mail merge settings wizard, check "Send emails to the recipients" checkbox and select "Email" data 
field from "Data source field to use for email address" pull-down list.  
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3. Type desired "Subject" line and enter text for the email message into "Message" entry field. It is 
possible to customize each email message by inserting values of data fields into email message. For 
example, type the following into "Message" field: 

Dear [First Name] [Last Name], 
Please find attached your monthly account statement. 
Your Support Team 

The above example assumes that there are "First Name" and "Last Name" data fields present in a data 
source. The values from these fields will be inserted into each customized email message, producing 
something like the following: 

Dear John Doe, 
Please find attached your monthly account statement.  
Your Support Team 

4. Press "Next>>" button to advance to the next settings screen. Select desired emailing method from 
the screen below. By default, the software will use your currently installed email client: 
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If you have selected a default emailing method, then no setup is necessary. However, this emailing 
method comes with certain restrictions. Due to Windows security policy you will be prompted to 
confirm sending of each email message. It is possible to send emails via current email client without 
confirming each outgoing message (uncheck "Use simple MAPI protocol" option). However, this ability is 
typically disabled in most corporate environments due to security reasons. 

The best method to send emails without any user interaction is via SMTP email server. Select "Use SMTP 
Internet E-mail Server" option if you want to use this method and press "Next>>" button.  

5. You would need to know SMTP server settings for the specific server used at your organization. Enter 
your name, email address, account user name, account password and SMTP server address.  

 

Text from entered into "Your Name" field will appear in the "From" field of all outgoing emails. This is 
the name that all recipients see next to each email message. Address entered into "E-mail Address" field 
will be used as "reply-to" address for all emails.  

Make sure that "User Name" and "Password" matches your SMTP account. These settings are crucial for 
correct connection to the SMTP server and sending emails.  
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6. Press "Advanced Server Options..." button to specify low level details like port number, security 
protocols and authentication method. 

Here is an example of settings for Gmail server: 

 

Press "OK" button to save settings. 

Press "Test Server Settings..." button to check server configuration by emailing a test message to your 
own email address specified in "E-mail Address" entry field. If all settings are correct, you should receive 
a test email message shortly. Check junk mail folder, because it is possible that it will be automatically 
classified as junk message. 

Press "Next >>"button to move to the next screen once finished configuring email settings. 
 

IMPORTANT: Most SMTP servers have a daily quota for sending emails. If you exceed a daily limit of 
outgoing email messages, then your account will be temporary suspended until next day. Please consult 
your Internet service provider or IT department for details. 
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Have a question? Email us at tech@evermap.com. 
 
Other AutoMailMerge tutorials: 
 
“Creating and Printing Multiple Labels per Page” is available for download from 
http://www.evermap.com/AutoMailMerge/PrintingMultipleLabelsPerPage.pdf 
 
Software product page is located at the following address: 
http://www.evermap.com/AutoMailMerge.asp 

http://www.evermap.com/AutoMailMerge/PrintingMultipleLabelsPerPage.pdf
http://www.evermap.com/AutoMailMerge.asp
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